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Skill

Exam Objective

Objective Number

Recording Macros

Assign shortcut keys.
Record simple macros.

1.4.9
1.4.8

Monitoring Macro Security

Manage macro security.

1.4.10

Arranging Document Views

KEY TERMS
• digital signature
• hacker
• macro
• master document
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393

394

Lesson 12
You are the president of the Lakeville.NET User’s Group, which is a group of
students, faculty, and professionals in the community whose purpose is to
educate, help build development skills, and provide a forum for networking.
This group meets monthly and schedules regular workshops and speakers
on relevant topics. In this role, you discover that you use many of the same
types of documents on a regular basis, and you would like to streamline the
process of creating similar documents. In this lesson, you learn to work
with outlines, arrange master documents and subdocuments, and record
and manage macros.
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SOFTWARE ORIENTATION
Outline View
When you open the Outline view from the View tab, the Outlining tab contains buttons
for working with long documents and arranging the document into smaller sections. The
Outlining tab is shown in Figure 12-1.
Demote to
lower level
Show
Promote to Outline Demote to
Levels
higher level levels lowest level

Insert looks for
an existing file to embed
into subdocument
Creates
Merge subdocuments
subdocuments
into one

Promote to
highest level
Move
Up

Split subdocuments into separate subdocuments
Move
Collapse
Down Expand

Show Text
Formatting

Close Outline
Unlink a
View button
subdocument
Collapse
Lock subdocuments to
Subdocuments
avoid unwanted changes

Show First Line Only.
Off by default
Show Document.
Expands group to
display more commands

Figure 12-1
Outlining tab

Use this figure as a reference throughout this lesson as well as the rest of this book.
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ARRANGING DOCUMENT VIEWS
The Bottom Line

Creating master documents enables you to work efficiently with large reports such as your research
paper or other long reports. These long documents are broken down into subdocuments making
it more manageable and easy to edit.

Working with a Master and Subdocuments
A master document is the main document created in Word, such as your research paper. A research paper or another long report contains information such as a title, thesis, introduction,
techniques, results, and works cited to name a few. This document can be a 60-page document,
and scanning through the whole document could be cumbersome. Working with a master document can organize the heading sections into smaller sections called subdocuments, which are
sections within the master document that have been separated into subsections. When a subdocument is created, it becomes a separate file from the master although it still remains linked to the
master document. This allows you to open a small 2- or 3-page document rather than a 20-page
document.
For example, you create a master document for long reports and research papers. When you fi nish
formatting your master document with heading styles, you can separate it into a subdocument
for each heading and its content. Subdocuments are created based on their heading styles; the
subdocument is saved with the heading as the filename.
As a student, you will most likely have to take a technical writing class for one of your core courses and prepare a research paper. As you begin working on your research paper, you will outline it
to make it more manageable and to keep yourself organized. Working with the master and subdocuments is similar to how you work on sections of your paper. You can edit from your whole
master document or work in the subdocument as a separate document. When you edit and save
subdocuments independently, the master document automatically gets updated because the subdocument is linked to the master document. When you need to review the master document, all
editing changes will appear in the document.

Saving the Master Document
To help you manage the master document, it is best to save the master document and all the subdocuments in the same folder. Creating a folder makes locating subdocuments quick. The document that you will work on is already formatted with heading styles. In this exercise, you learn to
create a folder, and then save the master document.

STEP BY STEP

Save the Master Document
OPEN the Hosting document from lesson folder.
1. To save the document in a specific folder, click the File tab, and then click Save As. Click
Computer and then click Browse.
The Save As dialog box opens for you to locate your flash drive.
2. Click the New folder button located under the address bar and type Master Hosting
and press Enter to accept the new folder name.
3. With the folder selected, click the Open button or double-click to place the master
folder in the address bar.
Creating a folder is easy and makes your job easier to locate the master document and
subdocuments. When naming a folder, choose a name closely related to the document.
4. In the File name box, type Master Proposal.
Figure 12-2 displays the file in the folder.
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Figure 12-2
Save As dialog box
Creates
a new folder

Location to master folder
on flash drive

Master Hosting folder
appears in address bar

File name box

5. Click the Save button to save the document in the Master Hosting folder.
PAUSE. LEAVE the document open for the next exercise.

Cross
Ref

Creating and saving documents is covered in Lesson 1.

Creating Subdocuments
A subdocument is part of the master document and is separated into small sections. Each subdocument has a unique filename based on the heading style that was applied to the document when
it was created. As a student, this feature is useful for a large research paper—you work on one
subdocument section at a time rather than having the whole document open. The first step is
identifying the levels within the subdocuments just like you would in creating an outline. For
example, Level 1, Level 2, and Level 3 is similar to creating an outline and identifying headings
with Roman numerals I, II, and II.
When formatting your research paper, you apply a heading style to each new section in your paper
(styles are covered in Lesson 3). When you are editing subdocuments separately, the master
document is automatically updated. The Outlining tab contains the Collapse and Expand subdocument buttons that correlate with the master document. In this exercise, you create subdocuments
that are saved separately.
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Create Subdocuments
USE the document open from the previous exercise.
1. Click the View tab. In the Views group, click the Outline button. The Outlining tab
opens and is placed by the Home tab.
2. In the Outline Tools group, click the drop-down arrow by Show Level and select Level 1
to make the document more manageable.
This document has already been formatted with heading styles; when the levels are
changed, the document collapses and only Level 1 displays on the screen as shown in
Figure 12-3.

Figure 12-3
Document displayed by Level 1
Click the Expand ( + ) button to
display content within heading

Click the plus symbol ( + )
to select a heading

3. In the Master Document group, click the Show Document button to display additional
commands as shown in Figure 12-4.
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Figure 12-4

Show Document displaying
additional commands
Click Show Document to display
additional commands

Create

The Collapse Subdocuments button will become
activated after a subdocument is created

4. Click the plus (+) symbol next to Introduction to select the heading. Even though you
cannot see it, the content within the heading is also selected.
5. Click the Create button in the Master Document group to create a subdocument.
Notice that Introduction has a subdocument icon on the left side and is surrounded by
a border with a continuous section break above and below the heading. This allows
Word to distinguish the beginning and end of a subdocument with a continuous flow
to the master document. A border indicates this is a subdocument. With your first
subdocument created, the Collapse Subdocuments button becomes active. If you
cannot see the continuous section break, select the Show/Hide button from the
Home tab.

Cross
Ref

Section breaks are covered in Lesson 5.
6. Select the plus (+) symbol next to the Account Information heading, and then click the
Create button.
A border is automatically placed around the subdocument.
7. Repeat your steps for the remaining headings: Indemnification/Warranties, Prohibited
Uses of Services and Products, Bandwidth and Utilization, Security/Software , Violation,
Confidentiality, and Refusal of Service .
The document should display as shown in Figure 12-5. A border appears around each
subdocument along with continuous section breaks.
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Figure 12-5
Document with subdocuments
Subdocument icon. When you click
the icon, the subdocument heading and
contents are selected

A border is placed around the
subdocument after it is created

Collapse Subdocuments button becomes
active after a subdocument is created

Continuous section breaks are automatically
inserted to separate subdocuments

PAUSE. LEAVE the document open to use in the next exercise.

Saving Subdocuments
The next step is to save the master document with the subdocuments. Word automatically creates
a filename for each of the subdocuments based on the text formatted with the heading styles. It
saves them as a separate file, but in the same folder. For example, the document that you are working on contains many headings with a Heading 1 style applied to them. Figure 12-4 shows each
of the headings in the document. When the master document is saved, each of the headings and
the text under the heading is saved into a separate file automatically. In this exercise, you learn to
save the master document with the subdocuments.

STEP BY STEP

Save Subdocuments
USE the document that is open from the previous exercise.
button on the Quick Access Toolbar to save the Master Proposal
1. Click the SAVE
document and the created subdocuments.
Word saves each subdocument as a separate file based on the heading style (Heading 1)
that was applied to the document. Each of the subdocuments are linked to the master
document.
2. CLOSE the master document.
PAUSE. LEAVE Word open.
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STEP BY STEP

View the Subdocuments in the Master Folder
1. OPEN the Master Hosting folder.
You started with one file in your Master Hosting folder and now you have several
subdocuments in the folder. When subdocuments are created and then saved, Word
automatically saves each subdocument as a separate file. Word uses the text within the
heading as the filename.
2. OPEN the Master Proposal document. The document opens in Print Layout view.
When opening a master document, the subdocuments show the location in a hyperlink
to the file. You see your flash drive letter followed by the Master Hosting folder and
then by the subdocument filename. By default the subdocuments are locked and
collapsed.
Figure 12-6 displays the document with the location of the saved subdocuments with
hyperlinks.

Figure 12-6
Master document with
subdocuments

Continuous section breaks
automatically inserted

Location of where the
subdocuments were saved

Press Ctrl then
click will open the hyperlink

3. When you are ready to follow a link in Word, press Ctrl, and then click one of the links.
Each hyperlink goes directly to the subdocument when you click on the link. Later in
this lesson, you open a subdocument.
PAUSE. LEAVE the document open to use in the next exercise.

Expanding and Collapsing Subdocuments
To view the master document with its contents, click the Expand Subdocuments button on the
Outlining tab. Once the Expand Subdocuments button is clicked, you can switch views and the
document remains expanded. The Collapse Subdocuments button closes the subdocuments. In
this exercise, you expand and collapse subdocuments.
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Expand and Collapse Subdocuments
USE the document that is open from the previous exercise.
1. Change the view of the document to Outline.
With the Outlining tab open, you can now work with the buttons in the Master
Document group.
button and notice that all subdocuments are
2. Click the Expand Subdocuments
shown along with their contents (see Figure 12-7).
Each heading and its contents now appear. Now that the subdocuments are expanded
the Expand Subdocuments button is replaced with the Collapse Subdocuments button.

Troubleshooting

If you do not see the headings and contents in a border, click the Show Document button in
the Master Documents group.

Figure 12-7
Subdocuments expanded
When subdocuments are expanded,
the Collapse Subdocuments button appears on the Ribbon

3. Click the Collapse Subdocuments

button to collapse each of the subdocuments.

The Expand Subdocuments button appears again.
PAUSE. LEAVE the document open to use in the next exercise.

Promoting and Demoting Subdocuments
When you rearrange levels in a master document, you move the subdocument heading to another
level by using the commands in the Outlining tab by either promoting or demoting the level. For
instance, to move a topic in the paper under another heading, you demote that heading. As you
continue working on your research paper, you come to realize that the Heading 1 style applied to
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one of the headings should be a Heading 2. In the Outlining tab, you have options to change the
levels of the headings by using the promote or demote buttons. It is easy to demote a Level 1 to a
Level 2 or vice versa. So in this case, you demote the Level 1 to a Level 2. In this exercise, you learn
to use promote and demote buttons.

STEP BY STEP

Promote and Demote Subdocuments
USE the document that is open from the previous exercise.
1. Click the Expand Subdocuments

button to expand all subdocuments.

Point at the plus (+) symbol next to the Account Information heading—notice that the
mouse pointer changes to four arrows.
2. Click the plus (+) symbol once to select the heading and all the contents within the
subdocument.
3. In the Outline Tools group, click the Demote

button once.

Did you see the Outline Level box change from a Level 1 to a Level 2? The Account
Information has been demoted to a Level 2 as shown in Figure 12-8.

Figure 12-8
Heading demoted
Promotes to highest
level, Level 1

Demotes to a
lower level

Outline Level

Demotes to body text

Promotes to
a higher level

“Account Information” demoted
to the next lower level

4. With the Account Information subdocument still selected, click the Promote
once.

arrow

The Account Information has been promoted back to a Level 1. Demote back to a Level 2.
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You can click the
drop-down arrow by the Outline
Level box to select the level.
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5. Click the SAVE button on the Quick Access Toolbar. The master document is saved
with the updated changes.
PAUSE. LEAVE the document open to use in the next exercise.

Reorganizing Subdocuments
Subdocuments can be rearranged within the master document. The order of subdocuments can
be changed by moving the subdocuments from one location to another using the command buttons on the Outlining tab or by dragging and dropping. Once you move a subdocument, you need
to unlink it and recreate it. You can also merge two or more subdocuments into one subdocument.
In this exercise, you reorganize subdocuments.

STEP BY STEP

Reorganize Subdocuments
USE the document that is open from the previous exercise.
1. Deselect Account Information by clicking in a blank area of the document screen.
2. Add a check mark next to Show First Line Only.
This displays a few lines for each of the subdocuments and hides the remaining
content—making the subdocuments more manageable.
3. Scroll down and click to select the plus (+) symbol by the Security/Software heading
and its contents.
4. Click the Show Document button to display the additional commands in the Master
Document group.
button (four times) until the
5. On the Outline Tools group, click the Move Down
heading is positioned below the continuous section break below Violation .
Hint, two continuous section breaks should appear above Security/Software .
The Security/Software subdocument is surrounded by a border, which extends to the
Confidentiality subdocument.

Another Way
Click the subdocument icon to select the heading
and contents, and drag and
drop to the new location.

STEP BY STEP

6. Delete the two continuous section breaks under Security/Software and Confidentiality.
Deleting these continuous section breaks makes it easy to unlink the subdocuments.
PAUSE. LEAVE the document open to use in the next exercise.

Unlink Subdocuments
USE the document that is open from the previous exercise.
Currently, there is only one subdocument icon for both levels as shown in Figure 12-9.
Both of these subdocuments are linked to the master document and must be unlinked to
create separate subdocuments.
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Figure 12-9

Repositioned subdocuments
Repositioning subdocuments places a border
around two subdocuments and displays one subdocument icon

1. Click the plus (+) symbol by Security/Software to select it, and then click the Unlink
button.
The subdocument icon disappears.
2. Click the Create button to create a subdocument.
This places a border around this level and the subdocument icon appears.
3. Click the plus (+) symbol by Confidentiality.
4. Check whether the Unlink button is showing. If it is, then click Unlink, and then click
Create. If the Unlink button is not displayed, click just the Create button.
5. Click the check box to turn off Show First Line Only. Change the Level to display
only Level 1.
Changing the display of the level makes it more manageable to create a subdocument
and see the borders around each of the subdocuments.
6. Click the Collapse Subdocuments button and a prompt appears asking Do you want to
save changes to the master document “Master Proposal.” Click OK .
Your screen should match Figure 12-10. Word automatically saves the subdocument
with a new filename and drops the last character of the filename and adds a 1 at
the end. The two additional files that you see in your flash drive are Securit1 and
Confidentialit1. Each time you create a subdocument, it is automatically linked to the
master document and the original subdocuments are no longer linked to the
master document.
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Figure 12-10
Master document with
hyperlinks with repositioned
subdocuments

Subdocuments
that have been
rearranged are
automatically given
a new filename

PAUSE. LEAVE the document open to use in the next exercise.

Editing an Individual Subdocument
Subdocuments can be edited directly in the master document, or you can open the subdocument
as a separate file in its own window. In this exercise, you edit a subdocument separately and within
the master document.

STEP BY STEP

Edit an Individual Subdocument
USE the document that is open from the previous exercise.
1. Point to the Master Hosting / Introduction subdocument hyperlink, press Ctrl and Click
to follow the hyperlink and open the subdocument in a separate window. It is now
ready for editing and formatting.
2. You will edit text in the first and second sentences. Select principles , guidelines, and
requirements from the first sentence. In the second sentence, select integrity, security,
reliability, and privacy. All seven words should be selected.

Cross
Ref

In Lesson 2, you learn to select text using different methods. To select multiple areas of text, press
CTRL and select the text.
3. Bold the selected text, and then change the font color to dark red.
4. Click SAVE on the Quick Access Toolbar; then close the Introduction subdocument file.
If prompted to save changes, click SAVE .
5. Click the Outlining tab to make it available with its commands.
6. In the Master Document group, click the Expand Subdocuments

button.

Notice the bolded dark red text under the Introduction heading. Changes made in the
Introduction subdocument automatically update the master document.
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7. Click the Close Outline View button to take you to the Print Layout view.
8. Scroll down to page 3.
9. Under the heading, Prohibited Uses of Services and Products , select the second
paragraph.
10. From the Design tab, select Page Borders.
11. Add a border around the paragraph by selecting the Borders tab to make it active.
12. Under the Setting section, select Shadow. Change the Width to 2¼, and then apply
Red, Accent 2 color.
A colored border with a 2¼ width is applied to the paragraph.
13. Click the Shading tab, and then select the fill color Red, Accent 2, Lighter 80% .
A shading is applied to the paragraph within the border.
14. Click OK .
15. Under the headings, General, System and Network , and Billing, select the contents with
bullets.
16. Change the bullets to the solid diamond. The bullets have been replaced with the new
bullets on the selected text.
17. SAVE the Master Proposal document, and then close the file. You have completed
editing the master document.
18. To view an independent subdocument, open the Prohibited Uses of Services and
Products subdocument from the Master Hosting folder. The changes that you made in
steps 10–16 are shown in the subdocument as shown in Figure 12-11.
Figure 12-11

Subdocument with changes

19. CLOSE the document.
LEAVE Word open.
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SOFTWARE ORIENTATION
Recording Macros
Do you find yourself performing the same task in Word over and over again? If so, recording
macros simplifies your task. You belong to the Lakeville.NET User’s Group, and you are responsible for providing everyone with copies of upcoming workshops. You bring together the
skills that you have learned from other lessons to record a macro. For instance, in Lesson 6,
you learn to create and format tables, and use formulas within the tables. You’re always on the
go and now you find yourself in a situation where you are not accomplishing much because
of repetitive tasks. It is essential that you learn about macros to help you manage your time
more wisely, increase productivity, and still have time for yourself. In this exercise, you learn
to record and run a macro.

RECORDING MACROS
The Bottom Line

STEP BY STEP

A macro is a recorded sequence of commands to automate a task. It is a series of commands and
actions that can be recorded and run whenever you need to perform the task. When a macro is
created, you can run it manually or assign it to run whenever a specific key or series of keystrokes
are pressed.

Assign Shortcut Keys
A keyboard shortcut is a combination of two or more keys to perform a specific action. In
the lessons that you have already covered, you applied a keyboard shortcut to open a new
document by pressing Ctrl + N or to bold text by pressing Ctrl + B. Word contains many
different shortcuts and these shortcuts are assigned to a specific action to perform,
therefore, cannot be used.
GET READY. If necessary, before you begin these steps, LAUNCH Word.
1. OPEN a blank document.
2. In the View tab, click the drop-down arrow by Macros to produce a menu (see
Figure 12-12).
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Figure 12-12
Macros menu
After macros are recorded,
you can view them here

Pause Recording. It will be activated
once you begin recording a macro

Record Macro opens the dialog box.
This is where you assign a macro
name and decide if you assign
a macro to a button or keyboard

3. Click Record Macro to open the Record Macro dialog box. In the dialog box, you need
to assign a name to the macro and decide which option to use to assign a macro. You
have two choices as shown in Figure 12-13. You can assign a macro by button or by
keyboard.
Figure 12-13
Record Macro dialog box
Macro name cannot
contain spaces

Choose how you want
to assign the macro

Option on where
to store macro
Add a description
to describe macro

4. In the Macro name box, type Upcoming _Workshops.
Spaces are not allowed; you need to add an underscore. Adding a number at the end of
the macro name is also valid.
5. Keep the default setting for Store macro in.
It will be stored in All Documents (Normal.dotm) .
You want it stored there because you will access this macro on a monthly basis. If
someone else is working on your computer and you’ve provided this person with the
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keyboard shortcut, he or she too can access the macro. (Hint: You can add the shortcut
key in the description, in case you forget it or want to share it.)
The first macro will be assigned to a keyboard command. This means whenever you
press the keyboard commands, the macro will run.
Before you click the Keyboard button, you want to add a description to the macro.
6. In the Description box, type Use this table for all upcoming workshops.
7. Click the Keyboard button to open the Customize Keyboard dialog box as shown in
Figure 12-14.
In the Commands box, the macro is stored in Normal.NewMacros.Upcoming_Workshops .
This shows the location of where the macro will be stored.
Figure 12-14
Customize Keyboard
dialog box

Location where
macro is stored

Categories box

Press keys
for keyboard
shortcut

If the keyboard shortcut is
assigned or unassigned
it will display here

Save changes in options

Description will
appear here

Assign button

Remove button Reset All button

8. It’s time to see whether a keystroke has been assigned to another command. In the
Press new shortcut key box, press C trl1T (do not type the plus symbol).
This shortcut key is already assigned to the HangingIndent command as shown in the
dialog box.
9. Press Backspace to remove Ctrl1T.
Let’s try another shortcut key.
10. Press Ctrl1Alt1T.
And again, this shortcut key is already taken by the ™ Trademark command. It may take
you several attempts to find an unassigned shortcut key.
11. Press Backspace to remove Ctrl1Alt1T.
12. Press Alt1T.
Notice that this keystroke is not assigned.
13. Click the Assign button to assign this shortcut key to the new macro. The Alt1T
command is moved to the Current keys box for this macro.
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The changes will be assigned in the Normal template instead of Document1. This
macro will be saved on the computer that you are recording the macro and can be
accessed by anyone who is working on your computer.

Take Note

1.4.9

Word allows you to override assigned keyboard keys, but you don’t want to do that. Find one that
is unassigned.
14. Click CLOSE .
PAUSE. LEAVE Word open for the next exercise.

How do you assign a
keyboard shortcut to a
macro?

Recording a Macro
Once you determine which method to assign the macro, the next step is recoding your steps.
While Word is recording a macro, you see the mouse pointer change to a recording pointer on
your screen. At this point, every keystroke and mouse click is recorded. When working with macros, you cannot use the mouse to select text. In this exercise, you learn to record your steps to
create and format a table.

STEP BY STEP

Record a Macro
The Record button has been enabled and you should see the mouse pointer change to a
recording pointer on your screen. As long as you see the icon on your document screen,
you are still recording your steps. If you need to take a break, click the Pause Recording
command in the Macros menu. If you pause during a macro, you can return by clicking
Resume Recorder.
GET READY. USE the document that is Table and then click open from the previous
exercise.
1. Click the Insert tab, and then click Insert Tables to open the dialog box.
2. Create a table that contains 4 columns and 7 rows. Click OK .

Cross
Ref

In Lesson 6, you learn to create tables using various methods and format using Tables Tools.
3. Type the information as shown in Figure 12-15.
Because you are recording a macro, you need to press Tab to move between cells and
press Shift1Tab to move back.

Figure 12-15
Upcoming Workshop document

4. After you type the data, click the Layout tab from the Tables Tools and Select Tables.
While you are recording a macro, you cannot use your mouse to select text or tables.
The whole table is now selected.
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5. In the Table Styles group of the Design tab, click the More button to display the gallery.
6. In the Grid Tables group, select Grid Table 4 – Accent 6 to apply a style to the table.
7. Use the arrow keys on the keyboard to move up to the first row that contains the
headings.
8. On the Layout tab, click Select in the Table group and choose Select Row, and then
select Align Center. For now, these are the only changes you will record for this macro.
9. The next step is to stop recording. Click the View tab, click Macros, and then click Stop
Recording.
You recorded your first macro and will be able to access it quickly. If you share your
computer with another individual, this person too can use the keyboard shortcut to
apply the macro as long as you provide him or her with the shortcut key. This table
can be used for all upcoming workshops—all you have to do is change the data.
10. CLOSE the document without saving. (Hint: When a warning prompt appears, click
Don’t Save.)

1.4.8
How do you record a macro?

PAUSE. LEAVE Word open for the next exercise.

Running a Macro
Once a macro is recorded, you can press the keyboard shortcut to run it in a blank or existing
document. In this exercise, you learn to run your macro in a blank document.

STEP BY STEP

Run a Macro
OPEN a blank document.
1. Press Alt1T. The table automatically appears on your document screen.
When you need to work on this table, you can now access it quickly, edit the data, and
then save with a new filename.
2. SAVE the document as Upcoming Workshops in the lesson folder on your flash drive,
and then CLOSE the file.
3. OPEN a blank document.
Now, let’s run the macro again another way.
4. On the View tab, click Macros, and then click View Macros to open the Macros dialog
box as shown in Figure 12-16.

Figure 12-16
Macros dialog box

Macro name

Click Run to run macro.
The highlighted macro will run
Open Visual Basic
in coding view
Create new macro
Delete selected macro
The Organizer provides
options to copy, delete,
and rename macros

Macro description
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5. Click Run. The table appears on the document screen.
Additional commands are available in the dialog box and will not be discussed in this
lesson. Some of these commands open the Visual Basic Application—this is where you
can create or edit a macro. If you accidently open it, just close the application.
6. CLOSE the document without saving.
PAUSE. LEAVE Word open for the next exercise.

Troubleshooting

Creating and running a macro takes practice. If your macro does not run correctly, delete the
macro and repeat your steps from the beginning.

Deleting a Macro
You determine you no longer need this macro and want to delete it. In this exercise, you learn to
delete a macro.

STEP BY STEP

Delete a Macro
OPEN a blank document.
1. On the View tab, click Macros, and then click View Macros to open the Macros dialog
box (refer to Figure 12-16).
2. Select the macro, and then click the Delete button.
3. A warning prompt appears asking Do you want to delete macro Upcoming_Workshops?
4. Click No. You can return later to delete. Click Cancel.
PAUSE. LEAVE Word open for the next exercise.
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SOFTWARE ORIENTATION
Controlling Macro Security
You learned to streamline your work using macros. Now, you are concerned about how security works with macros. Macro security involves active content in files that might come from
a site that has no digital signature or from someone who has written code with a virus. If
someone sends you a document and it contains macros with active content, it might pose a
security risk and harm your computer. A hacker is a person who writes malicious programs
such as viruses intended to harm your computer or access your data illegally. Every day we
hear about hackers breaking into large companies and accessing confidential information.
Organizations have security in place to identify and stop anyone from accessing data from
their network; so, it’s important to know, when working with macros, who your trusted
sources are. Word has a macro virus security that comes from trusted sources and locations.
This macro security determines whether the macro is safe to run on your computer. You want
reassurance that macros coming from other sources are from a trusted publisher. A
digital signature is a code digitally signed by a company or person. You can create your own
digital signature but it wouldn’t be issued from a trusted certificate authority. In this exercise,
you learn to review the securities on your system.
Record Macro

Pause Recording

Mapping group

Opens the
Visual Basic
editor

Macro Security.
Macros.
Opens the Macro
Opens the dialog box
where recorded Settings in the Trust Center
macros are stored

Restrict Editing.
Limit how others can
edit your document

Templates group

Figure 12-17
Developer tab

Use this figure as a reference throughout this lesson as well as the rest of this book.

MONITORING MACRO SECURITY
The Bottom Line

STEP BY STEP

Macro security has preventive measures in place to determine whether a macro source is safe to run.

Review Macro Security Settings
GET READY. If necessary, before you begin these steps, LAUNCH Word.
1. From the File tab, select Options on the Backstage page.
2. Select Trust Center from the Word Options dialog box.

1.4.10
How would you change the
macro settings?

In the Trust Center screen, Microsoft has provided links to articles on protecting your
privacy, computer, and security. At your leisure, take time to read these articles.
3. Click the Trust Center Settings button to open the Trust Center screen. In the left pane,
Macro Settings is highlighted.
This is where you manage how macros run. You can choose to disable all macros with
or without notification, disable all macros with the exception of those that are digitally
signed, or enable all macros that could harm your computer.
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Adding a check mark by Trust access to the VBA project object model allows access to
the Visual Basic for Applications object model. Leave the settings at the default
settings (see Figure 12-18).
4. Click the Cancel button to exit the Trust Center dialog box.
Figure 12-18
Trust Center

This area in
the Trust Center
manages how
macros run

PAUSE. LEAVE the Word Options dialog box open to use in the next exercise.

Now you will learn to add the Developer Tab to the ribbon.

STEP BY STEP

Review the Developer Tab
GET READY. USE the document that is open from the previous exercise.
1. Click Customize Ribbon on the left pane.
This screen is where you customize the Ribbon or, in this case, turn on a Ribbon tab
that is off by default.

Cross
Ref

In Lesson 14, you learn to customize the Ribbon with your favorite commands.
2. Under Customize the Ribbon, select the check box by Developer (refer to Figure 12-19).
3. Click OK .
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Figure 12-19
Customize Ribbon

By default,
the Developer tab
is off. Click check
box to display on
Ribbon

4. Click the Developer tab to display the groups and commands.
The Developer tab contains commands that are used with macros, which includes
codes, templates, controls used in forms, add-ins, and more (refer to Figure 12-17 for
details on the Developer tab).
Previously, you opened the Macros dialog box to run a macro that you created. From
the Developer tab, the Macros dialog box can be accessed in the Code group by
clicking the Macros button. In the same group, you can record a macro and pause a
recording—these are the same commands from the Macros group in the View tab.

1.4.10
How would you manage
macro security?

Take Note

Clearly the Developer tab contains more commands. The Macro Security button opens
the Trust Center. This displays the macro settings for your computer. If you have a
programming background or feel comfortable writing code, you can write your own
macro using the Visual Basic editor.
CLOSE Word.

To find additional information on macros, use the Help feature by pressing the F1 button or click
the Help icon.
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SKILL SUMMARY
In this lesson you learned to:

Exam Objective

Objective Number

Record Macros

Assign shortcut keys.
Record simple macros

1.4.9
1.4.9

Monitor Macro Security

Manage macro security.

1.4.10

Arrange Document Views

Knowledge Assessment

Multiple Choice
Select the best response for the following statements.

1. Where can you open Trust Center settings?
a. Backstage
b. Developer tab
c. View tab
d. a and b
2. Microsoft will protect your:
a. privacy.
b. computer.
c. unsafe sources.
d. a and b
3. By default, how many levels does the Outline View contain?
a. Nine
b. Eight
c. Seven
d. Five
4. Clicking the Show Document button in the Outlining tab displays:
a. Backstage view.
b. more commands.
c. Create.
d. None of the above
5. Clicking the Expand button will:
a. show all the text in the subdocument.
b. close the subdocument.
c. open only the selected content.
d. a and c
6. To view the hyperlinks in the subdocuments, you must:
a. open the master document after creating and saving the subdocument in the master
document.
b. open the original document.
c. open the individual subdocuments separately.
d. None of the above
7. Macros are used for:
a. boring work.
b. research papers.
c. repetitive work.
d. work that is not performed daily.
8. A macro that has been assigned a keyboard shortcut can be run in:
a. a blank document.
b. an existing document.
c. a template.
d. All of the above
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9. When assigning a keyboard shortcut, it is recommended that you use one that is:
a. assigned to a command.
b. designated to a command.
c. already used.
d. unassigned.
10. Which one of these keyboard shortcuts are not assigned?
a. Ctrl1B
b. Ctrl1I
c. Ctrl1H
d. Alt1Q

True/False
Circle T if the statement is true or F if the statement is false.

T F

1. A subdocument contains the whole document.

T F

2. Macros will not automate tasks.

T F

3. When you create subdocuments, they are saved with the master document.

T F

4. When recording a macro, you can format a document with many features to
enhance the document.

T F

5. When assigning a name to a macro, spaces can be used.

T F

6. A master document can be reorganized.

T F

7. Moving a subdocument to another location in the master document still retains
it as a subdocument.

T F

8. Short essays should be separated into subdocuments.

T F

9. If you plan to create subdocuments, identifying the heading should be the first
step especially if the document does not already contain heading styles.

T F 10. Macros can be accessed in both the View and Developer tabs.

Competency Assessment
Project 12-1: Creating a Simple Macro
In your job at Books and Beyond, you continue to work on documents that will be part of the
employee handbook. You create a simple macro to be used for this employee handbook. In this
project, you apply skills that you have learned from previous lessons.
GET READY. LAUNCH Word if not already running.
1. OPEN a blank document.
2. On the View tab, click Macros and then click Record Macro in the Macros group.
3. Type the information in the appropriate box:

Macro name : Books_and_Beyond
Description: Formatted report for B&B handbook.
4. Click Keyboard and in the Press new shortcut key box, type Alt + L . This is an
unassigned shortcut key.
5. Click Assign, then click Close.
6. In the Design tab, select the Basic (Stylish) Style Set from the Document Formatting
group.
7. Type BOOKS AND BEYOND. Apply Heading 1 from the Styles group on the Home tab.
8. Press Enter once.
9. Type Second section heading.
10. Select Heading 2 .
11. Press Enter twice.
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12. Type Third section heading.
13. Select Heading 3.
14. Press Enter twice.
15. Click Stop Recording from the Macros group on the View tab.
CLOSE the document without saving. LEAVE Word open for the next project.

Project 12-2: Creating Separate Files for the Books and Beyond Master Document
You work at Books and Beyond and your manager has asked you to work with this document and
create separate files from the master document. In your computer class, you learned about master
documents and how Word automatically saves subdocuments.
GET READY. LAUNCH Word if not already running.
1. OPEN Books Beyond from the lesson folder.
2. From the File tab, click Save As.
3. Click Browse and use the scroll bar to locate your flash drive. In the Save As dialog box,
click New folder and name it BOOKS BEYOND.
4. In the File name box, type Master Books and save it in the BOOKS BEYOND folder.
5. Select the heading, Acknowledgement, and format with the Heading 1 style.
6. Select the Introduction heading and format with the Heading 1 style.
7. Select the General Performance Expectation Guidelines heading and format with the
Heading 1 style.
8. On the View tab, click the Outline button.
9. In the Outline Tools group, click the drop-down arrow by Show Level to display Level 1.
10. Click the plus (+) symbol next to General Performance Expectation Guidelines.
11. Click the Demote button to change the level for the General Performance Expectation
Guidelines heading.
The heading is now a Level 2.
12. Click the Show Document button.
13. Select the plus (+) symbol next to Acknowledgement to select the heading and
contents under that header.
14. Click the Create button in the Master Document group.
15. Click the plus (+) symbol by Introduction to select the heading and contents under that
heading.
16. Click the Create button in the Master Document group.
17. Click the Save button on the Quick Access Toolbar, and then CLOSE the file.
18. OPEN the Master Books document and preview your document in Print Layout view.
You should see two hyperlinks CLOSE the file.
LEAVE Word open for the next project.

Proficiency Assessment
Project 12-3: Running the Books and Beyond Macro
You are ready to run the macro created from Project 12-1.
GET READY. LAUNCH Word if not already running.
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1. OPEN a blank document.
2. Press Alt1L .
3. SAVE the document as 12-3 B&B Report in the lesson folder on your flash drive, and
then CLOSE the file.
LEAVE Word open for the next project.

Project 12-4: Books and Beyond
In this project, you continue working with the files from Project 12-2.
GET READY. LAUNCH Word if not already running.
1. OPEN the Introduction document from the BOOKS BEYOND folder.
2. Use the Find and Replace command to find all occurrences of Books and Beyond and
replace with B&B. Change the formatting and apply the bold italic style, font size 12 pt,
underline style Words only, and dark blue font color. (There are 13 occurrences to find.)
3. Change all bullets to the number format and select 1) .
4. Change the number format listed under the Set Alarm and Deactivate Alarm headings
to a solid circle bullet.
5. SAVE the document in the BOOKS BEYOND folder on your flash drive.
6. OPEN the Master Books document and change the view to Outline.
7. Press CTRL1Click to open the Acknowledgement link and select I acknowledge from
the first paragraph and I understand from the fourth paragraph. Bold and change to
uppercase.
8. SAVE the document in the BOOKS BEYOND folder on your flash drive, and then CLOSE
both documents.
LEAVE Word open for the next project.

Mastery Assessment
Project 12-5: Creating a Macro with Formulas
Create a macro with formulas and format the table. Take a screenshot of the Macros dialog box to
validate that you completed this project and provide a copy to your instructor.
GET READY. LAUNCH Word if not already running.
1. OPEN a blank document.
2. Create a macro, named Expenses, and in the Description box, type Expense Report for
trips. Look for an unassigned shortcut key and assign it to this macro.
3. Create a table as shown in Figure 12-20, and then enter the data and apply the
formatting.
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Figure 12-20
Table document
Merge, center,
font size 26 pt,
row height 0.8”,
align center

Apply the Grid
Table 5 Dark style

Center, bold,
font size 12 pt

Key Total and align right

4. In the first blank cell in the last column, use the Formula dialog box to calculate the
hotel total cost. Delete the formula leaving the equal sign.
5. Type B4*3. Click OK .
6. Calculate the total cost for meals. Type B5*3.
7. Calculate the total cost for transportation. Type B6*2 .
8. Calculate the grand total cost summing the previous values. Use the third option to
format the number.
9. Click Stop Recording.
10. CLOSE the document without saving.
LEAVE Word open for the next project.

Project 12-6: Running Macros and Showing Field Codes
In Project 12-5, you created a macro to prepare a table in a table format that contains formulas. In
this project, your job is to run the macro and display the fields. Print a copy of both tables and
submit to your instructor. Before closing your computer, change the display back to its default
setting.
GET READY. LAUNCH Word if not already running.
1. OPEN a blank document.
2. Run the macro.
3. Change the display to show the field codes.
4. SAVE the document as 12-6 Expense Report in the lesson folder on your flash drive.
CLOSE Word.

